Notes, Cautions, and Warnings

⚠️ **NOTE:** A NOTE indicates important information that helps you make better use of your computer.

⚠️ **CAUTION:** A CAUTION indicates either potential damage to hardware or loss of data and tells you how to avoid the problem.

⚠️ **WARNING:** A WARNING indicates a potential for property damage, personal injury, or death.
Preface.............................................................................................................................................................................5
  Revision history...............................................................................................................................................................5
  Audience...........................................................................................................................................................................5
  Related Publications.........................................................................................................................................................5
  Contacting Dell Support..................................................................................................................................................6

1 Installing CITV................................................................................................................................................................7
  Introduction to CITV..........................................................................................................................................................7
  Installation Requirements..................................................................................................................................................7
  Deploying CITV...............................................................................................................................................................7
  Setting Up CITV.............................................................................................................................................................8
    Configuring the Time on the CITV Virtual Appliance.................................................................................................8
    Logging in to CITV.........................................................................................................................................................9
    Configuring CITV Settings............................................................................................................................................10
  Updating CITV...............................................................................................................................................................11
    Display the Current Version of CITV..........................................................................................................................11
    Check for Updates to CITV............................................................................................................................................11
    Install an Update to CITV...............................................................................................................................................12
    Updating CITV at a Dark Site........................................................................................................................................12
    Rebooting CITV...........................................................................................................................................................13

2 VASA Provider.............................................................................................................................................................14
  Configuring VASA Provider Settings............................................................................................................................14
  Registering VASA Provider............................................................................................................................................15
    Register VASA Provider With VMware vCenter.......................................................................................................15
    Sync Storage Data Between VASA Provider and VMware vCenter.........................................................................15
    Verify Vendor Provider Details................................................................................................................................16
  Using VASA Provider Information................................................................................................................................16
    Profile-Driven and Policy-Based Storage..................................................................................................................16
    View Dell VASA Provider storage capabilities.......................................................................................................16

3 Replay Manager Service for VMware............................................................................................................................18
  Configuring RMSV..........................................................................................................................................................18

4 Dell Storage vSphere Web Client Plugin.........................................................................................................................19
  Installing the Dell Storage vSphere Web Client Plugin..................................................................................................19
  Register the vSphere Web Client Plugin After an Upgrade Installation......................................................................19
  Removing the vSphere Web Client Plugin.....................................................................................................................20

A CITV Application Troubleshooting..............................................................................................................................21
  Viewing VASA Alerts and Events..................................................................................................................................21
  Troubleshooting VASA Provider..................................................................................................................................21
    Restart VASA Provider..................................................................................................................................................22
    Save VASA Provider Log Files..................................................................................................................................22
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Troubleshooting RMSV</td>
<td>22</td>
</tr>
<tr>
<td>Restart RMSV</td>
<td>23</td>
</tr>
<tr>
<td>Save RMSV Log Files</td>
<td>23</td>
</tr>
<tr>
<td>Troubleshooting the vSphere Web Client Plugin</td>
<td>23</td>
</tr>
<tr>
<td>Dell Storage Icon Is Missing</td>
<td>23</td>
</tr>
<tr>
<td>Plugin Summary and Monitor Page Appears Disabled</td>
<td>24</td>
</tr>
<tr>
<td>Snapshot and Snapshot Schedule Creation Fails</td>
<td>24</td>
</tr>
<tr>
<td>Cannot Enable Live Volume to Failover Automatically</td>
<td>24</td>
</tr>
<tr>
<td>Failure When Creating NFS Datastores</td>
<td>24</td>
</tr>
<tr>
<td>Managing an NFS Datastore Created Outside the Plugin</td>
<td>24</td>
</tr>
<tr>
<td>View vSphere Web Client Log Files</td>
<td>24</td>
</tr>
</tbody>
</table>
This guide provides instructions for installing the Compellent Integration Tools for VMware (CITV) and configuring the following applications:

- Dell VASA Provider
- Dell Replay Manager Service for VMware (RMSV)
- Dell Storage vSphere Web Client Plugin

Topics:
- Revision history
- Audience
- Related Publications
- Contacting Dell Support

Revision history

Table 1. Revision history

<table>
<thead>
<tr>
<th>Revision</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>March 2016</td>
<td>CITV version 3.1 general availability release</td>
</tr>
</tbody>
</table>

Audience

The intended audience of this guide is information technology professionals who have intermediate to expert knowledge of Dell Storage Centers, Enterprise Manager, and Replay Manager. This guide assumes administrative working knowledge of the VMware vSphere Client, VMware vCenter, and VMware ESXi.

Related Publications

The following documentation is available for client applications that are used with Dell storage products.

- Dell Compellent Best Practices with VMware vSphere 5.x
  Provides configuration examples, tips, recommended settings, and other storage guidelines a user can follow while integrating VMware vSphere with a Storage Center. This document answers many frequently asked questions with regard to how VMware interacts with Storage Center features, such as Dynamic Capacity, Data Progression, and Remote Instant Replay.

- Dell Storage vSphere Web Client Plugin Administrator’s Guide
  Describes how to use the vSphere Web Client Plugin to manage a Dell Storage Center with the VMware vSphere Web Client.

- Enterprise Manager Administrator’s Guide
  Provides configuration and management instructions for Enterprise Manager, which allows enterprise-level management of multiple Storage Centers, including setting up and monitoring replications and disaster recovery (DR) sites. In addition, Enterprise Manager provides various system-provided performance reports, as well as the ability to create custom reports.

- Replay Manager Administrator’s Guide
  Describes how to install Replay Manager and how to use the software to back up and restore data on a server.
• *Storage Center System Manager Administrator’s Guide*
  Describes how to use the Storage Center System Manager to configure and manage storage on a Storage Center.

**Contacting Dell Support**

Dell provides several online and telephone-based support and service options. Availability varies by country and product, and some services might not be available in your area. To contact Dell for sales, technical support, or customer services issues, go to [dell.com/support](http://dell.com/support).
Installing CITV

CITV is a virtual appliance that allows Dell Storage applications to be integrated with VMware vSphere environments.

Introduction to CITV

CITV allows integration of the Dell VASA Provider, Replay Manager Service for VMware, and vSphere Web Client Plugin with VMware vSphere.

- Dell VASA Provider gathers information about the available storage topologies, capabilities, and statuses of a Storage Center and passes this information to VMware vCenter, making it accessible to vSphere clients. This information allows VMware vCenter administrators to make intelligent decisions when selecting the datastores on which to place new virtual machines. To configure, register, and use the Dell VASA Provider, see VASA Provider.
- Dell Replay Manager Service for VMware (RMSV) enables consistent Replays of VMware virtual machines and datastores. To configure Dell Replay Manager Service for VMware, see Configuring RMSV.
- Dell Storage vSphere Web Client Plugin is a plugin for VMware vCenter that provides storage administrators the ability to manage Dell storage with the VMware vSphere Client. To install the Dell Storage vSphere Web Client Plugin on a VMware vCenter Server, see Installing the Dell Storage vSphere Web Client Plugin.

**NOTE:** All procedures in this guide are written for the VMware vSphere Client for Windows. However, the VMware vSphere Web Client can also be used to perform the procedures.

Installation Requirements

The Compellent Integration Tools for VMware Release Notes list the minimum hardware and software requirements for CITV installation.

For information about installing and configuring VMware software, see:

www.vmware.com/support

Deploying CITV

The CITV virtual appliance is delivered as an OVA (Open Virtual Appliance) file. The OVA file is named DellCompellentIntegrationTools_OVF10.ova and is deployed to a VMware vCenter Server using the Deploy OVF Template wizard.

**About this task**

**NOTE:** Assign a daily Replay Profile to the Storage Center volume on which CITV is being deployed to allow the CITV virtual appliance to be recovered.

**Steps**

1. Start the vSphere Client and connect to the VMware vCenter Server.
2. In the vSphere Client, select VMs and Templates.
3. Select Actions > Deploy OVF Template.
   The Deploy OVF Template wizard appears.
4. Specify the location of the DellCompellentIntegrationTools_OVF10.ova file in the Deploy from a file or URL field.
5. Click Next.
   The OVF Template Details page appears.
6. Click Next.
   The End User License Agreement page appears.
Read the license agreement and click **Accept**.

Click **Next**.

The **Name and Location** page appears.

Specify the name and location of the virtual appliance.

- (Optional) Change the name of the virtual appliance in the **Name** field. The default name of the virtual appliance is **Compellent Integration Tools for VMware**.
- (Optional) Select a folder in the **Inventory Location** pane to which to deploy the virtual appliance.

Click **Next**.

The **Host/Cluster** page appears.

Select the host or cluster on which to deploy the virtual appliance.

If a cluster is selected, click **Next** and select the host within the cluster on which to deploy the virtual appliance.

Click **Next**.

The **Storage** page appears.

Select the destination storage for the CITV virtual machine files.

Click **Next**.

The **Disk Format** page appears.

Select the format for the virtual disks.

Click **Next**.

- If network mapping is required, map the source network to a destination network on the **Network Mappings** page and click **Next**.
  
  The **Ready to Complete** page appears and displays the deployment settings of the virtual appliance.
- If network mapping is not required, the **Ready to Complete** page appears and displays the deployment settings of the virtual appliance.

Click **Finish**.

A dialog box appears that shows the progress of the deployment.

Click **Close** when the Completed Successfully message appears.

**Setting Up CITV**

After deploying CITV, configure the time on the CITV virtual appliance and then log on to the virtual appliance to configure the time zone and network settings.

- Configuring the Time on the CITV Virtual Appliance
- Logging in to CITV
- Configuring CITV Settings

**Configuring the Time on the CITV Virtual Appliance**

Make sure the time on the ESXi host is correct and then configure the CITV virtual appliance to synchronize its time with the ESXi host.

1. Start the vSphere Client and connect to the VMware vCenter Server.
2. Select **View > Inventory > Hosts and Cluster**.
   
   The **Hosts and Clusters** view opens.
3. Select the ESXi host and click the **Configuration** tab.
4. Click **Time Configuration**.
   
   The **Time Configuration** page opens.
5. Click **Properties**.
   
   The **Time Configuration** dialog box opens.
6. If the time or date is incorrect, enter the correct time or date in the appropriate field.
7. Click **OK**.
Select View > Inventory > VMs and Templates. The Virtual Machines & Templates view opens.

Right-click the CITV virtual appliance and select Edit Settings. The Virtual Machine Properties dialog box opens.

Click the Options tab and select the VMware Tools option.

Make sure the Synchronize guest time with host checkbox is selected.

Click OK.

## Logging in to CITV

Use the vSphere Client to log in to CITV.

1. Start the vSphere Client and connect to the VMware vCenter Server.
2. Select View > Inventory > View > VMs and Templates. The Virtual Machines & Templates view opens.
3. Right-click the CITV virtual appliance and select Open Console.
4. If the virtual appliance is not running, select VM > Power > Power On.
5. When the login prompt appears, enter the CITV login credentials:

```
# Welcome to Dell Compellent Integration Tools for VMware
# Version - 3.x.x.x
```

<table>
<thead>
<tr>
<th>Item</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Set the time zone (Current: UTC) Unset</td>
</tr>
<tr>
<td>2.</td>
<td>Configure network (eth0) Unset</td>
</tr>
<tr>
<td>3.</td>
<td>Configure VASA Unset</td>
</tr>
<tr>
<td>4.</td>
<td>Configure RMSV Unset</td>
</tr>
<tr>
<td>5.</td>
<td>Register vSphere Web Client Plugin with vCenter</td>
</tr>
<tr>
<td>6.</td>
<td>Unregister vSphere Web Client Plugin with vCenter</td>
</tr>
<tr>
<td>10.</td>
<td>Restart VASA provider</td>
</tr>
<tr>
<td>11.</td>
<td>Restart Replay Manager for VMware (RMSV)</td>
</tr>
<tr>
<td>12.</td>
<td>Reboot appliance</td>
</tr>
<tr>
<td>13.</td>
<td>Change root password</td>
</tr>
<tr>
<td>14.</td>
<td>Customer support</td>
</tr>
<tr>
<td>15.</td>
<td>Update appliance</td>
</tr>
<tr>
<td>16.</td>
<td>Logout</td>
</tr>
</tbody>
</table>

Enter selection [1 - 16]:

a. Type root at the login prompt and press Enter.

b. Type Fluid (case sensitive) at the password prompt and press Enter.

After logging in, the CITV command-line interface (CLI) prompt is displayed.
Configuring CITV Settings

After logging in to CITV for the first time, configure the time zone and network settings. In addition, Dell recommends changing the root password of CITV at this time.

Configure the Time Zone of CITV

1 Log in to CITV.
2 At the CLI prompt, type 1 and press Enter.
3 Specify the time zone using a geographical location.
4 When the correct time zone is displayed, type 1 and press Enter to save the changes.
5 When the time zone is set, press Enter to return to the main menu.

Related links
Logging on to CITV

Configure the Network Settings of CITV

1 Log in to CITV.
2 At the CLI prompt, type 2 and press Enter.
3 Type the host name of CITV and press Enter.
4 Type the IP address of CITV for the management network and press Enter.
5 Type the network mask for the management network and press Enter.
6 Type the gateway IP address for the management network and press Enter.
7 Type the IP address of the DNS server for the management network and press Enter.
8 To specify a second DNS server, type the IP address of the DNS server for the management network and press Enter. Otherwise, press Enter to skip this step.
9 When the values that you entered in the previous steps are displayed on the screen, type y and press Enter to save the changes.

NOTE: To configure the network settings of the VASA provider, see Configuring VASA Provider Settings.

10 When the network settings are configured, press Enter to return to the main menu.

Related links
Logging on to CITV

(Optional) Change the Root Password of CITV

1 Log in to CITV.
2 At the CLI prompt, type 13 and press Enter.
3 Type the new root password and press Enter.
4 Type the new root password again and press Enter.
5 When the root password is changed, press Enter to return to the main menu.

Related links
Logging on to CITV
Updating CITV

When an updated version of the CITV virtual appliance becomes available, it can be installed from the virtual appliance. If CITV is installed at a dark site, see Updating CITV at a Dark Site.

NOTE: CITV might reboot after an update is installed.

Display the Current Version of CITV

1. Log in to CITV.
2. At the CLI prompt, type 15 and press Enter. The following options are displayed:

-------------------------------------------
1. Appliance version
2. Check for updates
3. Install update
4. Return to main menu

Enter selection [1 - 4]:

3. Type 1 and press Enter. The current version of the virtual appliance is displayed.

Version - 03.xx.xx.xxx
Description - Updates to the Dell Compellent Integration Tools for VMware appliance
press [enter] to continue...

4. Press Enter to return to the virtual appliance update menu.

Related links
- Logging on to CITV

Check for Updates to CITV

1. Log in to CITV.
2. At the CLI prompt, type 15 and press Enter. The following options are displayed:

-------------------------------------------
1. Appliance version
2. Check for updates
3. Install update
4. Return to main menu

Enter selection [1 - 4]:

3. Type 2 and press Enter.

• If an update is not found, the following message is displayed:
  No available updates found

• If an update is found, the version number of the update is displayed.

4. Press Enter to return to the virtual appliance update menu.

Related links
- Logging on to CITV
Install an Update to CITV

Prerequisite

⚠️ CAUTION: Before updating CITV, make sure that no scheduled backups or restore operations are in progress.

Steps

1. Log in to CITV.
2. At the CLI prompt, type `15` and press Enter. The following options are displayed:

   ![Options Displayed](image.png)

   - Enter selection [1 - 4]:
   - Select 3 and press Enter.
   - If an update is found, the version number of the update is displayed and the update is installed.
   - Press Enter to return to the virtual appliance update menu.
3. Type `16` and press Enter to log out of CITV.
4. When the logon prompt appears, log back in to CITV.

Next step

Check the appliance version after the update completes. On some occasions, the version number is not refreshed. In that case, reboot CITV. The updated version is then displayed.

When Replay Manager Explorer is installed on a server with Replay Manager Service also installed, Dell recommends that you restart the Replay Manager Service after the CITV update completes.

---

Dell recommends that you reboot the CITV appliance after installing an update.

Related links

- Logging on to CITV
- Rebooting CITV

Updating CITV at a Dark Site

When CITV is installed at a site without Internet access, updates to CITV must be obtained from Dell Technical Support. The updates can then be made available using an internal web server or they can be copied directly to the virtual appliance.

Copy Updates to a Web Server

1. Contact Dell Technical Support to obtain the latest `DellCitvUpdate.zip` file.
2. Extract the contents of the `DellCitvUpdate.zip` file in a folder named `citvupdate` at the root directory of the web server.
   - For example, if the root directory of the web server is `C:\inetpub\wwwroot`, extract the contents of the zip file to `C:\inetpub\wwwroot\citvupdate`.
3. Verify access to the updates by using a web browser to go to `http://web_server_address/citvupdate/manifest/manifest-latest.xml`.
4. Log in to CITV.
5. Type `99` and press Enter to access the interactive shell.
6. Open the `/etc/hosts` file.
Add the following entry at the end of the hosts file:

citv.compellent.com[IP_address_of_web_server]

Save changes to the hosts file and type exit to return to the CLI.

Install the updates as described in Updating CITV.

Related links
Logging on to CITV

Copy Updates to the Virtual Appliance

1. Contact Dell Technical Support to obtain the latest DellCitvUpdate.zip file.
2. Using a computer with Internet access, download an unzip tool for CentOS release 5.11, which is the operating system of the virtual appliance.
3. Use Secure Copy (SCP) to copy the DellCitvUpdate.zip file and unzip the RPM file from a local computer to the virtual appliance.
4. Log in to CITV.
5. Type 99 and press Enter to access the interactive shell.
6. Install the unzip tool:
   
rpm -ivh [unzip_package_name].rpm
7. Create a directory named citvupdate in the root directory:
   
mkdir citvupdate
8. Extract the update files to the citvupdate directory:
   
unzip DellCitvUpdate.zip -d citvupdate
10. Find the string http://citv.compellent.com/citvupdate and change it to file:///root/citvupdate.
11. Save changes to the provider-deploy.xml file and type exit to return to the CLI.
12. Install the updates as described in Updating CITV.

Related links
Logging on to CITV

Rebooting CITV

CITV might need to be rebooted after an update is installed.

Prerequisite

⚠️ **CAUTION:** Before rebooting CITV, make sure no scheduled backups or restore operations are in progress.

Steps

1. Log in to CITV.
2. At the CLI prompt, type 12 and press Enter.
3. Type y and press Enter. The following messages are displayed:
   
Broadcast message from root...

The system is going down for reboot NOW!
4. When the login prompt appears, log back in to CITV.

Related links
Logging on to CITV
The Dell VASA Provider gathers information about the available storage topologies, capabilities, and statuses of Storage Centers, as well as Storage Center events and alerts. The VASA provider passes this information to VMware vCenter, making it accessible to vSphere clients. This information allows VMware vCenter administrators to make informed decisions when selecting the datastores on which to place new virtual machines.

## Configuring VASA Provider Settings

### Prerequisites
- Make sure that Enterprise Manager Data Collector is communicating with Storage Center.
- Deploy CITV and configure the time zone and network settings.
- Identify the host name or IP address of the Enterprise Manager Data Collector.
- Identify the web server port number of the Enterprise Manager Data Collector. The default value is 3033.
- Identify the user name and password of an existing Enterprise Manager user with reporter, volume manager, or administrator privileges.
- Map the Enterprise Manager user to one or more Storage Centers.
  - Refer to the Enterprise Manager Administrator’s Guide for details about Enterprise Manager user and Storage Center mappings.
- Provide a user name and password for the VASA provider user. These credentials are required to register the VASA provider as a Storage Provider on the VMware vCenter Server.

### Steps
1. Log in to CITV.
2. At the CLI prompt, type 3 and press Enter.
3. Type the host name or IP address of the Enterprise Manager Data Collector and press Enter.
4. Type the web server port number of the Enterprise Manager Data Collector and press Enter.
5. Type the user name of an existing Enterprise Manager user and press Enter.
6. Type the password of the existing Enterprise Manager user from the previous step and press Enter.
7. Retype the password and press Enter to confirm the password.
8. Create a VASA provider user by typing a user name and pressing Enter.
9. Create a password for the VASA provider user by typing a password and pressing Enter.
10. Retype the password and press Enter to confirm the password.
11. Press Enter to return to the main menu.
12. Type 10 and press Enter to stop and restart the VASA provider.

**NOTE:** The VASA provider must be stopped and restarted whenever changes are made to the VASA provider configuration.

### Related links
- Logging on to CITV
Registering VASA Provider

The Dell VASA Provider must be registered to establish a connection between the VMware vCenter Server and VASA Provider. After VASA Provider is registered, VMware vCenter collects alarm data from VASA Provider every 10 seconds. In addition, a Sync command can be used to manually synchronize data between VASA Provider and VMware vCenter.

NOTE: Before VASA Provider can be registered, the CITV appliance must validate DNS resolution to the vCenter Server. The CITV CLI prompts you to validate the DNS configuration before allowing you to register VASA Provider.

Register VASA Provider With VMware vCenter

1. Start the vSphere Client and connect to the VMware vCenter Server.
2. Select View > Administration > Storage Providers.
   The Storage Providers view opens.
3. Click Add.
   The Add Vendor Provider dialog box opens.
4. Type a descriptive name for the VASA Provider in the Name field.
5. Type the URL of the VASA Provider in the URL field. The URL of the VASA provider is:

   https://server_address:8443/vasa/services/vasaService

   server_address is the host name or IP address of the virtual appliance on which the VASA provider is located.
6. Type the VASA provider user name, specified in step 8 of Configuring VASA Provider Settings, in the Login field.
7. Type the VASA provider password, specified in step 9 of Configuring VASA Provider Settings, in the Password field.
8. Click OK.
   The vSphere Client displays a thumbprint of the certificate for the VASA provider host.
9. Click Yes to trust the VASA provider host.
10. Click Refresh All.
    If a synchronization has occurred, the date and time of the synchronization appears in the Last Sync Time column and the Provider Status in the Vendor Provider Details pane changes to online.

Sync Storage Data Between VASA Provider and VMware vCenter

1. Start the vSphere Client and connect to the VMware vCenter Server.
2. Select View > Administration > Storage Providers.
   The Storage Providers view opens.
3. Select the VASA Provider with which to synchronize storage data from the Vendor Providers list.
4. Click Sync.
5. Click Refresh All.
   If the Sync command was successful, the date and time of the synchronization appears in the Last Sync Time column and the Provider Status changes to online in the Vendor Provider Details pane.
Verify Vendor Provider Details

After the Dell VASA Provider is registered, select the newly created storage provider from the Vendor Providers list and verify that the following vendor ID and model ID appear in the table on the Vendor Provider Details pane:

- **Supported Vendor IDs** – COMPELNT
- **Supported Model IDs** – Compellent Vol

If the IDs do not appear, make sure that Dell VASA Provider is properly registered.

Using VASA Provider Information

The storage information that the VASA provider gathers allows VMware vCenter administrators to perform storage management.

Profile-Driven and Policy-Based Storage

The VASA provider supports Profile-Driven Storage, which categorizes volumes by performance and stores this information in storage profiles. Some of the benefits of Profile-Driven Storage include:

- Rapid, intelligent provisioning of applications
- Application service levels that match available storage
- Better visibility into the available storage pool

Policy-Based Storage Management helps further provision virtual machines by automating datastore placement decisions.

For more information, visit the VMware vSphere Support Center at:

www.vmware.com/support

View Dell VASA Provider storage capabilities

Storage capabilities define a specific set of storage characteristics that are guaranteed by a storage system. The storage capabilities defined by the Dell VASA Provider can be displayed in the VM Storage Profile view.

1. Start the vSphere Client, and connect to the VMware vCenter Server.
2. Select View > Management > VM Storage Profiles.
   The VM Storage Profiles view opens.
3. Click Manage Storage Capabilities in the toolbar below the navigation bar. The Manage Storage Capabilities dialog box opens and displays a list of system and user-defined storage capabilities.
   The Dell VASA Provider defines the following storage capabilities:

   **Table 2. VASA Provider storage capabilities**

<table>
<thead>
<tr>
<th>Storage Profile</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Non-production</td>
<td>Not for production use, may not be redundant</td>
</tr>
<tr>
<td>Capacity, RAID 5/6</td>
<td>7 K drives, RAID 5, or RAID 6</td>
</tr>
<tr>
<td>Capacity, RAID 5/6, Replicated</td>
<td>7 K drives, RAID 5, or RAID 6, volume is source of replication</td>
</tr>
<tr>
<td>Storage Profile</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Capacity, RAID 10</td>
<td>7 K drives, RAID 10</td>
</tr>
<tr>
<td>Capacity, RAID 10, Replicated</td>
<td>7 K drives, RAID 10, volume is source of replication</td>
</tr>
<tr>
<td>Capacity, Multi-RAID</td>
<td>7 K drives, multiple RAID levels</td>
</tr>
<tr>
<td>Capacity, Multi-RAID, Replicated</td>
<td>7 K drives, multiple RAID levels, volume is source of replication</td>
</tr>
<tr>
<td>Performance, RAID 5/6</td>
<td>15 K or 10K drives, RAID 5, or RAID 6</td>
</tr>
<tr>
<td>Performance, RAID 5/6, Replicated</td>
<td>15 K or 10K drives, RAID 5, or RAID 6, volume is source of replication</td>
</tr>
<tr>
<td>Performance, RAID 10</td>
<td>15 K or 10K drives, RAID 10</td>
</tr>
<tr>
<td>Performance, RAID 10, Replicated</td>
<td>15 K or 10K drives, RAID 10, volume is source of replication</td>
</tr>
<tr>
<td>Performance, Multi-RAID</td>
<td>15 K or 10K drives, multiple RAID levels</td>
</tr>
<tr>
<td>Performance, Multi-RAID, Replicated</td>
<td>15 K or 10K drives, multiple RAID levels, volume is source of replication</td>
</tr>
<tr>
<td>High Performance, RAID 5/6</td>
<td>SSD drives, RAID 5, or RAID 6</td>
</tr>
<tr>
<td>High Performance, RAID 5/6, Replicated</td>
<td>SSD drives, RAID 5, or RAID 6, volume is source of replication</td>
</tr>
<tr>
<td>High Performance, RAID 10</td>
<td>SSD drives, RAID 10</td>
</tr>
<tr>
<td>High Performance, RAID 10, Replicated</td>
<td>SSD drives, RAID 10, volume is source of replication</td>
</tr>
<tr>
<td>High Performance, Multi-RAID</td>
<td>SSD drives, multiple RAID levels</td>
</tr>
<tr>
<td>High Performance, Multi-RAID, Replicated</td>
<td>SSD drives, multiple RAID levels, volume is source of replication</td>
</tr>
<tr>
<td>Multi-Tier</td>
<td>Data Progression</td>
</tr>
<tr>
<td>Multi-Tier, Performance, Replicated</td>
<td>Data Progression with 15 K or 10K drives, volume is source of replication</td>
</tr>
<tr>
<td>Multi-Tier, High Performance</td>
<td>Data Progression with SSD drives</td>
</tr>
<tr>
<td>Multi-Tier, High Performance, Replicated</td>
<td>Data Progression with SSD drives, volume is source of replication</td>
</tr>
</tbody>
</table>

For information about using VM Storage Profiles to define the storage capabilities that are required by applications running on a virtual machine, visit the VMware vSphere Support Center at [www.vmware.com/support](http://www.vmware.com/support).
Replay Manager Service for VMware (RMSV) enables Replay Manager to communicate with VMware vCenter and create consistent Replays of VMware virtual machines and datastores on a Dell Storage Center.

Configuring RMSV

To allow Replay Manager to communicate with VMware vCenter, RMSV must be configured with information about the VMware vCenter Server.

Prerequisites

⚠️ CAUTION: Errors might occur on the VMware ESXi host if multiple instances of RMSV, on multiple CITV virtual appliances, are configured to communicate with a single VMware vCenter Server. Each instance of RMSV must be configured to communicate with a different VMware vCenter Server.

- Deploy CITV and configure the time zone and network settings.
- Identify the host name or IP address of the VMware vCenter Server.
- Identify the user name and password of a VMware vCenter user with administrator privileges.

Steps

1. Log in to CITV.
2. When the CLI appears, type `4` and press Enter.
3. Type the host name or IP address of the VMware vCenter Server and press Enter.
4. Type the user name of the VMware vCenter user with administrator privileges and press Enter.
5. Type the password of the user with administrator privileges and press Enter.
6. Retype the password and press Enter to confirm the password.
7. Type `11` and press Enter.

   RMSV attempts to connect to the VMware vCenter Server. If a `Connected successfully` message is displayed, continue to Step 8. If a `Connection to vCenter failed` message is displayed, verify the server information and repeat the previous steps.

   ✨ NOTE: If a server certificate message is displayed, type `y` and press Enter to trust the certificate.

8. Add the VMware vCenter Server to Replay Manager Explorer using the host name or IP address of CITV and the user name and password of a VMware vCenter user with administrator privileges.

   Refer to the Replay Manager Administrator’s Guide for details about adding the VMware vCenter Server to Replay Manager.

   ✨ NOTE: Replay Manager management tools (such as Replay Manager Explorer) must be installed on a computer that has connectivity to the CITV virtual appliance.

Related links

- Logging on to CITV
Dell Storage vSphere Web Client Plugin

The Dell Storage vSphere Web Client Plugin is a plugin for VMware vCenter that provides storage administrators the ability to manage Dell storage with the VMware vSphere Web Client.

Installing the Dell Storage vSphere Web Client Plugin

To install the Dell Storage vSphere Web Client Plugin, register the plugin with VMware vCenter.

Prerequisites

- Deploy CITV and configure the time zone and network settings.
- Identify the host name or IP address of the VMware vCenter Server.
- Identify the user name and password of a VMware vCenter user with administrator privileges.
- Make sure that Enterprise Manager Data Collector is communicating with Storage Center.

Steps

1. Log in to CITV.
2. At the CLI prompt, type 5 and press Enter.
3. Type the host name or IP address of the VMware vCenter Server and press Enter.
4. Type the user name of a VMware vCenter Server user with administrator privileges and press Enter.
5. Type the password of the user with administrator privileges and press Enter.
6. If necessary, retype the password and press Enter to confirm the password.

NOTE: If a server certificate message is displayed, type y and press Enter to trust the certificate.

7. Type the host name or IP address of CITV and press Enter.
8. Type y and press Enter.
9. After the vSphere Web Client Plugin is installed, press Enter to return to the main menu. Refer to the Dell Storage vSphere Web Client Plugin Administrator’s Guide for details about managing and using the vSphere Web Client Plugin.

Related links

- Logging on to CITV

Register the vSphere Web Client Plugin After an Upgrade Installation

The vSphere Web Client Plugin must be reregistered if you perform an upgrade installation of the CITV appliance.

After a successful upgrade of the CITV appliance, a reboot is required. You then must unregister and reregister the vSphere Web Client Plugin from the CITV appliance’s CLI menu. This action removes the old plugin and registers the new plugin to vCenter.

After performing these steps, if the Dell Storage icon does not appear in the vSphere Web Client, restart the vSphere Web Client service. See Troubleshooting the vSphere Web Client Plugin.
Removing the vSphere Web Client Plugin

To remove the vSphere Web Client Plugin, unregister the plugin from VMware vCenter.

Prerequisites

- Identify the host name or IP address of the VMware vCenter Server.
- Identify the user name and password of a VMware vCenter user with administrator privileges.

Steps

1. Log into CITV.
2. At the CLI prompt, type 6 and press Enter.
3. Type the host name or IP address of the VMware vCenter and press Enter.
4. Type the user name of a VMware vCenter user with administrator privileges and press Enter.
5. Type the password of the user with administrator privileges and press Enter.
6. Type y and press Enter to remove the vSphere Web Client Plugin.
7. After the vSphere Web Client Plugin is removed, press Enter to return to the main menu.
8. To view the changes in the VMware vCenter Web client, log out and log back in.

Related links

Logging on to CITV
To handle any issues with the CITV application:

- Use the alerts and events in VMware vCenter and the VASA provider troubleshooting procedures to troubleshoot issues with Dell VASA Provider.
- Use the RMSV troubleshooting procedures to troubleshoot issues with Dell Replay Manager Service for VMware.
- Use the vSphere Web Client Plugin troubleshooting procedures to troubleshoot issues with Dell Storage vSphere Web Client Plugin.

Topics:

- Viewing VASA Alerts and Events
- Troubleshooting VASA Provider
- Troubleshooting RMSV
- Troubleshooting the vSphere Web Client Plugin

### Viewing VASA Alerts and Events

Two VMware vCenter alarms can be triggered upon receiving alarm information from the VASA provider:

- **Datastore capability alarm** – This alarm triggers if VMware vCenter detects that the capability requirements are not being met.
- **Thin-provisioned LUN capacity exceeded** – This alarm triggers if VMware vCenter detects that a thin-provisioned LUN is exceeding its capacity threshold.

Alarms are displayed in the **Triggered Alarms** view on the **Alarms** tab of the datastore or on the **Alarms** view located at the bottom of the vSphere Client.

When a thin-provisioned LUN capacity exceeded alarm is received, the VMware vCenter Storage Monitoring Service posts an event to the VMware vCenter Server. This event can be displayed in the **Events** view on the **Tasks & Events** tab of the datastore or in the **Events** view on the root folder of the vSphere Client.

### Troubleshooting VASA Provider

If the VMware vCenter Server is unable to connect to the VASA provider:

- Verify that the VASA provider URL is properly registered on the VMware vCenter Server. See Registering VASA Provider.
- Verify that the VASA provider is running. See Restart VASA Provider.

If no datastore capabilities are being displayed in VMware vCenter:

- Verify that a valid vendor ID and model ID are listed for the registered storage provider on the VMware vCenter Server. See Verify Vendor Provider Details.
- Verify that the Storage Center on which the datastores are located have been added to the Enterprise Manager. See the Enterprise Manager Administrator’s Guide.
- Verify that the VASA provider is running. See Restart VASA Provider.

If further troubleshooting is required, Dell Technical Support might need a copy of the VASA provider logs for analysis. See Restart VASA Provider.
NOTE: A known issue with the VASA API prevents description information from being displayed in event messages.

## Restart VASA Provider

Use option 10 in the CLI to restart the VASA provider.

1. Log in to CITV.
2. At the CLI prompt, type `10` and press Enter. The following messages are displayed:
   ```
   Waiting 15 seconds for the service to restart
   Starting Tomcat                                     [ OK ]
   ```
   The Tomcat service, which the VASA provider uses to communicate with Enterprise Manager, is stopped and restarted.
   - If `[ OK ]` is displayed, the VASA provider started successfully.
   - If `[ Failed ]` is displayed, the VASA provider failed to start.

**Related links**
- Logging on to CITV

## Save VASA Provider Log Files

Use option 14 in the CLI to save the VASA provider log file to a zip file:

1. Log in to CITV.
2. At the CLI prompt, type `14` and press Enter. The following options are displayed:
   ```
   1. Gather support information
   2. Return to main menu
   Enter selection [1 - 2]:
   ```
   3. Type `1` and press Enter. The zip file with the logs is saved to the root directory of the virtual appliance.
   4. Use Secure Copy (SCP) to copy the zip file from the virtual appliance to a local computer.
      When the zip file is on a local computer, it can be sent to Dell Technical Support.

**Related links**
- Logging on to CITV

## Troubleshooting RMSV

If the Replay Manager is unable to connect to the VMware vCenter Server:

- Verify that the host name or IP address of the VMware vCenter Server is correct and the VMware vCenter Server user has administrator privileges. See Configuring RMSV.
- Verify that RMSV is running. See Save RMSV Log Files.

If further troubleshooting is required, Dell Technical Support might need a copy of RMSV logs for analysis. See Save RMSV Log Files.
Restart RMSV

Use option 11 in the CLI to restart RMSV and verify that it starts.

1. Log in to CITV.
2. At the CLI prompt, type 11 and press Enter. The following messages are displayed:

   Waiting 15 seconds for the service to restart
   Starting replaymanager: [ OK ]

   RMSV is stopped and restarted.

   • If [ OK ] is displayed, RMSV started successfully.
   • If [ Failed ] is displayed, RMSV failed to start.

Related links
   Logging on to CITV

Save RMSV Log Files

Use option 14 in the CLI to save the RMSV log file to a zip file.

1. Log into CITV.
2. At the CLI prompt, type 14 and press Enter. The following options are displayed:

   1. Gather support information
   2. Return to main menu

   Enter selection [1 - 2]:

3. Type 1 and press Enter. The zip file with the logs is saved to the root directory of the virtual appliance.
4. Use Secure Copy (SCP) to copy the zip file from the virtual appliance to a local computer.
   When the zip file is on a local computer, it can be sent to Dell Technical Support.

Related links
   Logging on to CITV

Troubleshooting the vSphere Web Client Plugin

Dell Storage Icon Is Missing

If the Dell Storage icon does not appear in the Administration pane of the vSphere Web Client:

• Verify that the host name or IP address of the VMware vCenter Server is correct and the VMware vCenter Server user has administrator privileges. See Restart RMSV.
• Verify that the vSphere Web Client Plugin is running. See Installing the Dell Storage vSphere Web Client Plugin.
• Restart the vSphere Web Client service.
  • For a Windows-based vCenter server, restart the vSphere Web Client service by accessing Server Manager > Services > VMware vSphere Web Client service. Select Restart to restart the service.
  • For a Linux-based vCenter Server appliance, use one of the following commands to restart the service:
    • service vsphere-client restart
    • /etc/init.d/vsphere-client restart
If further troubleshooting is required, Dell Technical Support might need a copy of vSphere Web Client log files for analysis. See View vSphere Web Client Log Files.

**Plugin Summary and Monitor Page Appears Disabled**

Summary information might not display in the vSphere Web Client Plugin. Information will appear blank on the summary page (Summary tab, then Dell Storage tab) and monitor page (Monitor tab, then Dell Storage tab).

Ensure that the credentials you entered on the Manage tab for vCenter server and Enterprise Manager configuration are correct.

**Snapshot and Snapshot Schedule Creation Fails**

When using an NFS datastore to create a snapshot or a snapshot schedule, ensure that the NFS datastore is hosted on a FluidFS v5 system.

**Cannot Enable Live Volume to Failover Automatically**

Live Volume configured to fail over automatically and promote the secondary volume might fail if the following requirements are not met:

- Type is Synchronous
- Synchronous mode is High Availability
- Source and target Storage Centers are at version 6.7 or higher

Select a datastore or RDM that meets these requirements. Optionally, modify the datastore to meet these requirements or create a new datastore or RDM.

**Failure When Creating NFS Datastores**

When using an existing NFS export to create a datastore, ensure that the required ACLs are pre-configured for the NFS export.

**Managing an NFS Datastore Created Outside the Plugin**

For NFS datastores created outside the vSphere Web Client Plugin, verify that you invoke the Dell Storage view for the corresponding datastore at least once. This action will retrieve details of the NFS datastore.

In addition, ensure that the vSphere Web Client Plugin can validate the datastore with the registered Enterprise Manager configuration.

**View vSphere Web Client Log Files**

For additional information, refer to the following publications:

- To view the vSphere Web Client log files, refer to the VMware Knowledge Base article Location of vSphere Web Client 5.x service logs (2004090).
- To change the logging level, refer to the VMware Knowledge Base article Enabling debug logging on the VMware vSphere 5.x/6.0 Web Client service (2011485).