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About This Guide
This guide provides instructions for installing the Dell Storage Integration Tools for VMware (DSITV) and for configuring Replay Manager 
Service for VMware (RMSV) and Dell Storage vSphere Web Client Plugin

Revision History
Document number: 680-131-002

Revision Date Description

A March 2019 Initial release

Audience
The intended audience of this guide is information technology professionals who have intermediate to expert knowledge of Dell Storage 
Centers, Dell Storage Manager, and Replay Manager. This guide assumes administrative working knowledge of the VMware vSphere Client, 
VMware vCenter, and VMware ESXi.

NOTE: Throughout this document, Dell Storage Manager (2016 and later) and Enterprise Manager (2015 and earlier) are 
synonymous.

Related Publications
The following documentation is available for client applications that are used with Dell storage products.

• Dell Storage SC Series Best Practices with VMware vSphere 5.x–6.x 

Provides configuration examples, tips, recommended settings, and other storage guidelines a user can follow while integrating VMware 
vSphere with a Storage Center. This document answers many frequently asked questions about how VMware interacts with Storage 
Center features, such as Dynamic Capacity, Data Progression, and Data Reduction.

• Dell Storage vSphere Web Client Plugin Administrator’s Guide

Describes how to use the vSphere Web Client Plugin to manage a Storage Center with the VMware vSphere Web Client.

• Dell Storage Manager Administrator’s Guide

Provides configuration and management instructions for Dell Storage Manager. Dell Storage Manager provides enterprise-level 
management of multiple Storage Centers, including setting up and monitoring replications and disaster recovery (DR) sites. In addition, 
it provides various system-provided performance reports, and the ability to create custom reports.

• Replay Manager Administrator’s Guide

Describes how to install Replay Manager and how to use the software to back up and restore data on a server.

Contacting Dell
Dell provides several online and telephone-based support and service options. Availability varies by country and product, and some services 
might not be available in your area.

To contact Dell for sales, technical support, or customer service issues, go to Dell.com/support.

• For customized support, type your system service tag on the support page and click Submit.

• For general support, browse the product list on the support page and select your product.

Preface
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Installing DSITV
This section describes DSITV components and how to install DSITV.

Introduction to DSITV
DSITV integrates the Replay Manager Service for VMware (RMSV) and Dell Storage vSphere Web Client Plugin with VMware vSphere.

• Replay Manager Service for VMware (RMSV) ensures consistent snapshots of VMware virtual machines and datastores. To configure 
RMSV, see Configuring RMSV.

• Dell Storage vSphere Web Client Plugin is a plugin for VMware vCenter that provides storage administrators the ability to manage Dell 
storage with the VMware vSphere Client. To install the Dell Storage vSphere Web Client Plugin on a VMware vCenter Server, see 
Installing the Dell Storage vSphere Web Client Plugin.

• For information about installing and configuring VMware software, see:

www.vmware.com/support

Software Requirements
The following lists identify the minimum software requirements for the DSITV components.

• Replay Manager Service for VMware (RMSV)

– Storage Center OS version: 6.7

– Replay Manager Explorer version: 7.8

– VMware ESX/ESXi version: 5.5–6.5

– VMware vCenter Web Client Server version: 5.5–6.5

• Dell Storage vSphere Web Client Plugin

– Dell Storage Manager (Enterprise Manager): 2016 R3

– Storage Center OS version: 6.7

– VMware ESXi version: 5.5–6.5

– VMware vCenter Web Client Server version: 5.5–6.5

– FluidFS version: 5.0

NOTE: The Dell Storage Manager Data Collector is also required for the Dell Storage vSphere Web Client Plugin version 
5.0. See the Dell Storage Manager Installation Guide for information about installing Data Collector.

Deploying DSITV
The DSITV virtual appliance is delivered as an OVA (Open Virtual Appliance) file. The OVA file is named DSITV-05.00.02.XXX.ova and is 
deployed to a VMware vCenter Server using the Deploy OVF Template wizard.

1 Start the vSphere Client and connect to the VMware vCenter Server.

2 In the vSphere Client, select VMs and Templates.

3 Select Actions > Deploy OVF Template.

The Deploy OVF Template wizard opens.

4 Specify the location of the .ova file in the Deploy from a file or URL field.

5 Click Next.

The OVF Template Details page opens.
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6 Click Next.

The End User License Agreement page opens.

7 Read the license agreement and click Accept.

8 Click Next.

The Name and Location page opens.

9 Specify the name and location of the virtual appliance.

• (Optional) Change the name of the virtual appliance in the Name field. The default name of the virtual appliance is Dell Storage 
Integration Tools for VMware.

• (Optional) Select a folder in the Inventory Location pane to which to deploy the virtual appliance.

10 Click Next.

The Host/Cluster page opens.

11 Select the host or cluster on which to deploy the virtual appliance.

If a cluster is selected, click Next and select the host within the cluster on which to deploy the virtual appliance.

12 Click Next.

The Storage page opens.

13 Select the destination storage for the DSITV virtual machine files.

14 Click Next.

The Disk Format page opens.

15 Select the format for the virtual disks.

16 Click Next.

• If network mapping is required, map the source network to a destination network on the Network Mappings page and click Next. 
The Ready to Complete page opens and displays the deployment settings of the virtual appliance.

• If network mapping is not required, the Ready to Complete page opens and displays the deployment settings of the virtual 
appliance.

17 Click Finish.

A dialog box opens to show the progress of the deployment.

18 Click Close when the Completed Successfully message is displayed.

Assign a daily Replay Profile to the Storage Center volume on which DSITV is being deployed to allow the DSITV virtual appliance to be 
recovered.

Setting Up DSITV
After deploying DSITV, configure the time on the DSITV virtual appliance and then log on to the virtual appliance to configure the time zone 
and network settings.

Configuring the Time on the DSITV Virtual Appliance
Make sure the time on the ESXi host is correct and then configure the DSITV virtual appliance to synchronize its time with the ESXi host.

1 Start the vSphere Client and connect to the VMware vCenter Server.

2 Select View > Inventory > Hosts and Cluster.

The Hosts and Clusters view opens.

3 Select the ESXi host and click the Configuration tab.

4 Click Time Configuration.

The Time Configuration page opens.

5 Click Properties.

The Time Configuration dialog box opens.

6 If the time or date is incorrect, type the correct time or date in the appropriate field.

7 Click OK.
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8 Select View > Inventory > VMs and Templates.

The Virtual Machines & Templates view opens.

9 Right-click the DSITV virtual appliance and select Edit Settings.

The Virtual Machine Properties dialog box opens.

10 Click the Options tab and select the VMware Tools option.

11 Make sure the Synchronize guest time with host checkbox is selected.

12 Click OK.

Logging In to DSITV
Use the vSphere Client to log in to DSITV.

1 Start the vSphere Client and connect to the VMware vCenter Server.

2 Select View > Inventory > View > VMs and Templates.

The Virtual Machines & Templates view opens.

3 Right-click the DSITV virtual appliance and select Open Console.

4 If the virtual appliance is not running, select VM > Power > Power On.

5 When the login prompt appears, type the DSITV login credentials.

After you log in, the CLI menu is displayed:

################################################################
#   Welcome to Dell Storage Integration Tools for VMware       #
#                       Version - 05.00.02.XXX                 #
################################################################
    Item                                                  Status
    ----------------------------------------------------  ------
1.  Set the time zone (Current: UTC) .................... Unset
2.  Configure network (eth0) ............................ Unset
3.  Configure RMSV ...................................... Unset
4.  Register vSphere Web Client Plugin with vCenter
5.  Unregister vSphere Web Client Plugin with vCenter
11. Restart Replay Manager for VMware (RMSV)
12. Reboot appliance
13. Change root password
14. Customer support
15. Update appliance
16. Logout
Enter selection [1 - 16]:

a Type root at the login prompt and press Enter.
b Type Fluid (case sensitive) at the password prompt and press Enter.

After logging in, the DSITV command-line interface (CLI) prompt is displayed.

Configuring DSITV Settings
After logging in to DSITV for the first time, configure the time zone and network settings. In addition, Dell recommends changing the root 
password of DSITV now.

Configure the Time Zone of DSITV

1 Log in to DSITV.

2 At the CLI prompt, type 1 and press Enter.

3 Specify the time zone using a geographical location.
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4 When the correct time zone is displayed, type 1 and press Enter to save the changes.

5 When the time zone is set, press Enter to return to the main menu.

Configure the Network Settings of DSITV

1 Log in to DSITV.

2 At the CLI prompt, type 2 and press Enter.

3 Type the host name of DSITV and press Enter.

4 Type the IP address of DSITV for the management network and press Enter.

5 Type the network mask for the management network and press Enter.

6 Type the gateway IP address for the management network and press Enter.

7 Type the IP address of the DNS server for the management network and press Enter.

8 To specify a second DNS server, type the IP address of the DNS server for the management network and press Enter. Otherwise, 
press Enter to skip this step.

9 When the values that you entered in the previous steps are displayed on the screen, type y and press Enter to save the changes.

10 When the network settings are configured, press Enter to return to the main menu.

(Optional) Change the Root Password of DSITV

1 Log in to DSITV.

2 At the CLI prompt, type 13 and press Enter.

3 Type the new root password and press Enter.

4 Type the new root password again and press Enter.

5 When the root password is changed, press Enter to return to the main menu.

Display the Current Version of DSITV

1 Log in to DSITV.

2 At the CLI prompt, type 15 and press Enter. The following options are displayed:

-------------------------------------------
1. Appliance version
2. Check for updates
3. Install update
4. Return to main menu
Enter selection [1 - 4]:

NOTE: Options 2 and 3 are not applicable for updates from DSITV version 4.x to DSITV version 5.x.

3 Type 1 and press Enter. The current version of the virtual appliance is displayed.

Version - 05.00.02.XXX
Description - Updates to the Dell Storage Integration
Tools for VMware appliance
press [enter] to continue...

4 Press Enter to return to the virtual appliance update menu.
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Replay Manager Service for VMware
Replay Manager Service for VMware (RMSV) enables Replay Manger to communicate with VMware vCenter and create consistent 
Replays of VMware virtual machines and datastores on a Dell Storage Center.

RMSV Data Migration
Upgrading from earlier versions of DSITV requires a migration of RMSV data.

You can choose to migrate the RMSV data created in DSITV 4.x to DSITV 5.0 during the RMSV configuration process (see Configuring 
RMSV). DSITV prompts you to migrate data unless one of the following conditions is met:

• You have already migrated data from DSITV 4.x to DSITV 5.0.

• You chose to configure DSITV 5.0 without migrating the earlier data.

After you configure RMSV, the data migration option is no longer displayed and you can no longer migrate data from the earlier release.

NOTE: Each restore point increases the time it takes for the data migration to finish.

After migration, the following data becomes accessible to DSITV 5.0:

• List of defined Storage Centers

• Email service settings and snapshot notifications email

• License status and serial number information

• Jobs schedule

• Backup sets and restore point status reports

• Related virtual machine and datastore backup data

NOTE: If you are running DSITV earlier than version 4.1, you must first upgrade to DSITV 4.1. Then, you can migrate the data 
from DSITV 4.1 to DSITV 5.0 as indicated.

Configuring RMSV
To allow Replay Manager to communicate with VMware vCenter, RMSV must be configured with information about the VMware vCenter 
Server.

CAUTION: Errors might occur on the VMware ESXi host if multiple instances of RMSV, on multiple DSITV virtual appliances, are 
configured to communicate with a single VMware vCenter Server. Each instance of RMSV must be configured to communicate 
with a different VMware vCenter Server.

• Deploy DSITV and configure the time zone and network settings.

• Identify the host name or IP address of the VMware vCenter Server.

• Identify the user name and password of a VMware vCenter user with administrator privileges.

• Decide whether to migrate RMSV data from DSITV 4.1. For more information, see RMSV Data Migration

1 Log in to DSITV.

2 At the CLI prompt, type 3 (Configure RMSV) and press Enter.

If you are upgrading from DSITV 4.1, DSITV begins the RMSV configuration process and asks if you want to migrate data from an 
existing DSITV 4.1 appliance. If you have an existing DSITV 4.1 appliance with data that you would like to migrate, continue with step 3. 
If prompted to migrate data, continue with step 4.
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3 To begin the data migration, type y when prompted and continue with the following steps:

NOTE: If you have already configured RMSV or migrated from a DSITV 4.1 appliance, the migration option is not 
available.

a Enter the IP address or host name of the DSITV appliance from which to migrate the data.

DSITV authenticates the host and asks if you want to continue connecting.

b Type yes when asked to confirm that you want to continue connecting.

DSITV adds the host to the list of known hosts, stops the Replay Manager on that host, and begins copying the RMSV data 
files.

c After the files are migrated, DSITV disables the Replay Manager on that host, restarts Replay Manager, and indicates that the 
data migration has completed. Continue with step 4.

4 Type the host name or IP address of the VMware vCenter Server and press Enter.

5 Type the user name of the VMware vCenter user with administrator privileges and press Enter.

6 Type the password of the user with administrator privileges and press Enter.

7 Retype the password and press Enter to confirm the password.

8 Type 11 and press Enter.

RMSV attempts to connect to the VMware vCenter Server. If a Connected successfully message is displayed, continue to 

step 8. If a Connection to vCenter failed message is displayed verify the server information and repeat the steps 4 through 

7. For additional information, see Troubleshooting RMSV.

NOTE: If a server certificate message is displayed, type y and press Enter to trust the 
certificate.

9 Add the VMware vCenter Server to Replay Manager Explorer using the host name or IP address of DSITV and the user name and 
password of a VMware vCenter user with administrator privileges.

See the Replay Manager Administrator’s Guide for details about adding the VMware vCenter Server to Replay Manager.

NOTE: Replay Manager management tools such as Replay Manager Explorer must be installed on a computer that has 
connectivity to the DSITV virtual appliance.

Related link

Logging In to DSITV
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Dell Storage vSphere Web Client Plugin
The Dell Storage vSphere Web Client Plugin is a plugin for VMware vCenter that provides storage administrators the ability to manage Dell 
storage with the VMware vSphere Web Client.

Installing the Dell Storage vSphere Web Client Plugin
To install the Dell Storage vSphere Web Client Plugin, register the plugin with VMware vCenter.

• Deploy DSITV and configure the time zone and network settings.

• Identify the host name or IP address of the VMware vCenter Server.

• Identify the user name and password of a VMware vCenter user with administrator privileges.

• Make sure that Dell Storage Manager Data Collector is communicating with Storage Center.

1 Log in to DSITV.

2 At the CLI prompt, type 4 and press Enter.

3 Type the host name or IP address of the VMware vCenter Server and press Enter.

4 Type the user name of a VMware vCenter Server user with administrator privileges and press Enter.

5 Type the password of the user with administrator privileges and press Enter.

6 If necessary, retype the password and press Enter to confirm the password.

NOTE: If a server certificate message is displayed, type y and press Enter to trust the 
certificate.

7 Type the host name or IP address of DSITV and press Enter.

8 Type y and press Enter.

9 After the vSphere Web Client Plugin is installed, press Enter to return to the main menu.

Refer to the Dell Storage vSphere Web Client Plugin Administrator’s Guide for details about managing and using the vSphere Web 
Client Plugin.

Related link

Logging In to DSITV

Removing the vSphere Web Client Plugin
To remove the vSphere Web Client Plugin, unregister the plugin from VMware vCenter.

• Identify the host name or IP address of the VMware vCenter Server.

• Identify the user name and password of a VMware vCenter user with administrator privileges.

1 Log in to DSITV.

2 At the CLI prompt, type 5 and press Enter.

3 Type the host name or IP address of the VMware vCenter and press Enter.

4 Type the user name of a VMware vCenter user with administrator privileges and press Enter.

5 Type the password of the user with administrator privileges and press Enter.

6 Type y and press Enter to remove the vSphere Web Client Plugin.

7 After the vSphere Web Client Plugin is removed, press Enter to return to the main menu.

8 To view the changes in the VMware vCenter Web client, log out and log back in.

3
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DSITV Application Troubleshooting
To handle any issues with the DSITV application:

• Use the RMSV troubleshooting procedures to troubleshoot issues with Dell Replay Manager Service for VMware.

• Use the vSphere Web Client Plugin troubleshooting procedures to troubleshoot issues with Dell Storage vSphere Web Client Plugin.

Topics:

• Troubleshooting RMSV

• Troubleshooting the vSphere Web Client Plugin

Troubleshooting RMSV
If the Replay Manager is unable to connect to the VMware vCenter Server:

• Verify that the host name or IP address of the VMware vCenter Server is correct and the VMware vCenter Server user has 
administrator privileges. See Configuring RMSV.

• Verify that RMSV is running. See Save RMSV Log Files.

If further troubleshooting is required, Dell Technical Support might need a copy of RMSV logs for analysis. See Save RMSV Log Files.

Restart RMSV
Use option 11 in the CLI to restart RMSV and verify that it starts.

1 Log in to DSITV.

2 At the CLI prompt, type 11 and press Enter. The following messages are displayed:

Waiting 15 seconds for the service to restart
Starting replaymanager:                                  [ OK ] 
RMSV is stopped and restarted.

• If [ OK ] is displayed, RMSV started successfully.

• If [ Failed ] is displayed, RMSV failed to start.

Save RMSV Log Files
Use option 14 in the CLI to save the RMSV log file to a zip file.

1 Log in to DSITV.

2 At the CLI prompt, type 14 and press Enter. The following options are displayed:

1. Gather support information
2. Return to main menu
Enter selection [1 - 2]:

3 Type 1 and press Enter. The zip file with the logs is saved to the root directory of the virtual appliance.

4 Use Secure Copy (SCP) to copy the zip file from the virtual appliance to a local computer.

When the zip file is on a local computer, it can be sent to Dell Technical Support.

A
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Troubleshooting the vSphere Web Client Plugin

Dell Storage Icon Is Missing
If the Dell Storage icon does not appear in the Administration pane of the vSphere Web Client:

• Verify that the host name or IP address of the VMware vCenter Server is correct and the VMware vCenter Server user has 
administrator privileges. See Restart RMSV.

• Verify that the vSphere Web Client Plugin is running. See Installing the Dell Storage vSphere Web Client Plugin.

• Restart the vSphere Web Client service.

– For a Windows-based vCenter server, restart the vSphere Web Client service by accessing Server Manager > Services > VMware 
vSphere Web Client service. Select Restart to restart the service.

– For a Linux-based vCenter Server appliance, use one of the following commands to restart the service:

◦ service vsphere-client restart 

◦ /etc/init.d/vsphere-client restart 

If further troubleshooting is required, Dell Technical Support might need a copy of vSphere Web Client log files for analysis. See View 
vSphere Web Client Log Files.

Plugin Summary and Monitor Page Appears Disabled
Summary information might not display in the vSphere Web Client Plugin. Information will appear blank on the summary page (Summary 
tab, then Dell Storage tab) and monitor page (Monitor tab, then Dell Storage tab).

Ensure that the credentials you entered on the Manage tab for vCenter server and Dell Storage Manager configuration are correct.

Snapshot and Snapshot Schedule Creation Fails
When using an NFS datastore to create a snapshot or a snapshot schedule, ensure that the NFS datastore is hosted on a FluidFS v5 
system.

Cannot Enable Live Volume to Failover Automatically
Live Volume configured to fail over automatically and promote the secondary volume might fail if the following requirements are not met:

• Type is Synchronous

• Synchronous mode is High Availability

• Source and target Storage Centers are at version 6.7 or later

Select a datastore or RDM that meets these requirements. Optionally, modify the datastore to meet these requirements or create a new 
datastore or RDM.

Failure When Creating NFS Datastores
When using an existing NFS export to create a datastore, ensure that the required ACLs are pre-configured for the NFS export.
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Managing an NFS Datastore Created Outside the Plugin
For NFS datastores created outside the vSphere Web Client Plugin, verify that you invoke the Dell Storage view for the corresponding 
datastore at least once. This action will retrieve details of the NFS datastore.

In addition, ensure that the vSphere Web Client Plugin can validate the datastore with the registered Dell Storage Manager configuration.

View vSphere Web Client Log Files
For additional information, refer to the following publications:

• To view the vSphere Web Client log files, refer to the VMware Knowledge Base article Location of vSphere Web Client 5.x service logs 
(2004090).

• To change the logging level, refer to the VMware Knowledge Base article Enabling debug logging on the VMware vSphere 5.x/6.0 Web 
Client service (2011485).

Registration Failure Related to TLS
Registration of the vSphere Web Client Plugin could fail if the vCenter Server is configured with TLS 1.0 disabled.

14 DSITV Application Troubleshooting
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